Modify

Ticket #164 (closed enhancement: duplicate)

Opened 3 years ago

Last modified 3 years ago

Not really a bug ... more encouragement!!

Reported by: softfoot@hotmail.com Owned by: alamaison
Priority: minor (e.g. uncommon, cosmetic, has workaround) Milestone:
Component: authentication Version:
Keywords: Cc:

Description

I know that using key files for authentication is a future enhancement, but that would turn this project from "very good" to "by marvelous!".

However, when you do it please, please, please make storage of the passkey to the key file optional (so that it remembers the keyfile but you can choose if to be challenged for the password or have it stored.

Dave

Attachments

Change History

comment:1 Changed 3 years ago by alamaison

  • Status changed from new to closed
  • Resolution set to duplicate

Thanks for you encouragement.

Publickey is planned (#18). It won't have an option to store the key's password because, presumably, if you'd wanted to use it without a password you wouldn't have given it a password in the first place!

That said, we do plan (eventually) to support key agents such as pageant so you'll only need to enter the password once as long as the agent is running (#154).

* Marked duplicate of #18 *

View

Add a comment

Modify Ticket

Change Properties
<Author field>
Action
as closed
The resolution will be deleted. Next status will be 'reopened'
Next status will be 'closed'Mark duplicate
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.