Ticket #266 (closed defect: wontfix)

Opened 4 years ago

Last modified 4 years ago

An error occurred during the installation of assembly 'Microsoft.VC80.CRT

Reported by: nick.radov@optum.com Owned by: alamaison
Priority: critical (affects core workflow) Milestone: 0.9.x Bug sprint
Component: installer Version: 0.8.0
Keywords: Cc:

Description

Swish setup failed with this error

An error occurred during the installation of assembly 'Microsoft.VC80.CRT,type="win32",version="8.0.50727.6195",publicKeyToken="1fc8b3b9a1e18e3b",processorArchitecture="amd64". Please refer to Help and Support for more information.

I am running Windows 7 Enterprise SP1 (64 bit). I ran the installation program swish-0.8.0.exe as Administrator.

Attachments

Swish Setup.png Download (27.5 KB) - added by nick.radov@optum.com 4 years ago.
Screen snapshot of error message
Error 1935.png Download (13.3 KB) - added by nick.radov@optum.com 4 years ago.
Microsoft Visual C++ 2005 Redistributable (x64) setup error

Change History

Changed 4 years ago by nick.radov@optum.com

Screen snapshot of error message

comment:1 Changed 4 years ago by alamaison

  • Status changed from new to accepted

The Visual Studio 2005 CRT is failing to install but it's not clear why.

Could you try installing it manually from  http://www.microsoft.com/en-us/download/details.aspx?id=18471 and post here whether you are successful or not? If you are successful, please try reinstalling Swish and, again, let us know here if that works.

This isn't a machine with an Itanium CPU, by any chance, is it?

Changed 4 years ago by nick.radov@optum.com

Microsoft Visual C++ 2005 Redistributable (x64) setup error

comment:2 Changed 4 years ago by alamaison

  • Priority changed from major (affects peripheral workflow) to critical (affects core workflow)
  • Status changed from accepted to closed
  • Resolution set to wontfix
  • Milestone set to 0.7.x Bug sprint

This isn't a bug in Swish, it's a problem with Windows and will also prevent you installing other programs that rely on the Visual Studio CRT. It can have all sorts of causes but  here is a likely answer. Even though the article is about VC90, it should apply to the VC80 error you are encountering.

An alternative solution, which people have had success with, is to run a Windows 'Repair' installation.

I'm closing this bug because it is not caused by Swish.

Note: See TracTickets for help on using tickets.